Message Index Start New Topic Photo Gallery FAQ and Use Tips Bob's Rock Shop

Posted in response to Spray Coolant on a Genie? from John Gonzales-Lusk on March 29, 2008 at 11:25:48:

Re: Spray Coolant on a Genie?

John,

I have had a Genie for over 10 years and never had a problem like yours. There should be no vibration from the Genie. If you have the same water system that I ahve then the brass blocks that have plastic hoses attached should not move from where you place them in the pan. It sounds like you have a problem with the shafts or the motor. Does it have rubber shock absorbers on the bottom of the motor mounts? If not then that may be your problem.

Joe D.

From Joe D. - March 31, 2008 at 07:53:40

Message: 66295

Message Index Start New Topic Photo Gallery FAQ and Use Tips Bob's Rock Shop

Agate   Alabaster   Alunite   Angelite   Assortments   Astrophyllite   Aventurine   Block Simulant   Cacoxenite   Calcite   Chalcedony   Charoite   Chrysocolla   Chrysoprase   Coral (Fossilized)   Dinosaur Dung (Coprolite)   Dolomite   Eudialite   Fossil Shell (Coquinite)   Goldstone   Graphic Stone   Hypersthene (Bronzite)   Indian Paint Rock   Ivoryite   Jade   Jasper   Jet   Lapis Lazuli   Larimar   Lepidolite   Marble   Obsidian   Petrified Wood   Pipestone   Printstone   Psilomelane   Quartz   Rainbow Pyrite   Rhodonite   Rhyolite   Ruby-in-Fuchsite   Seraphinite (Clinoclore)   Serpentine   Shell   Soapstone   Sodalite   Tiger Eye   Todolite   Travertine   Tumbling Rough   Turquoise   Unakite  

Bob Keller